关于Linux Sudo堆缓冲区溢出致本地提权漏洞的安全预警

发布者:戚腾飞发布时间:2021-01-28浏览次数:17

近期接网络安全厂商安全通报,Linux Sudo存在堆缓冲区溢出致本地提权漏洞(CVE-2021-3156),普通用户可以通过利用此漏洞,在默认配置sudo的Linux主机上获取root权限。由于,Sudo是大多数Unix和Linux相关操作系统中包含的功能强大的实用程序,而该漏洞细节也已在互联网上公开,因此存在明显的安全隐患,请使用Unix和Linux相关操作系统的师生用户及时修补该漏洞,避免被恶意用户利用

该漏洞详情和处置措施如下:

漏洞详情:

Linuxsudo命令存在堆缓冲区溢出漏洞,通过该漏洞,成功利用漏洞的任何本地用户可在无需root密码的情况下将本身权限提升为root权限,即攻击者在拥有低权限账号情况下可以提升权限到root权限执行命令。

影响范围:

旧版本 sudo 1.8.2<=1.8.31p2

稳定版 sudo 1.9.0<=1.9.5p1

检测方法:

在非root用户登录情况下输入命令:sudoedit –s /,如果回显错误以“sudoedit:”开头则表明该sudo版本有漏洞,如果对系统打入补丁后该错误回显将以“usage”开头。

处置建议:

Redhat等Linux发行版已紧急发布修复补丁,需要尽快升级相应补丁,sudu版本升级可以访问sudu官方下载网站(https://www.sudo.ws/download.html,也可以通过操作系统补丁升级修补。

1、CentOS系统

1)CentOS 6:默认版本的sudo在受影响范围,CentOS官方已停止更新,建议考虑升级操作系统大版本和强化用户访问策略;

2)CentOS 7:升级到sudo-1.8.23-10.el7_9.1或更高版本;

3)CentOS 8:升级到sudo-1.8.29-6.el8_3.1或更高版本。

2、Ubuntu系统

1)Ubuntu 20.04 LTS版本用户,建议升级到如下版本:

sudo-1.8.31-1ubuntu1.2

sudo-ldap-1.8.31-1ubuntu1.2

2)Ubuntu 18.04 LTS版本用户,建议升级到如下版本:

sudo-1.8.21p2-3ubuntu1.4

sudo-ldap-1.8.21p2-3ubuntu1.4

3)Ubuntu 16.04 LTS版本用户,建议升级到如下版本:

sudo-1.8.16-0ubuntu1.10

sudo-ldap-1.8.16-0ubuntu1.10

建议在升级前做好数据备份工作,避免出现意外。

3、Debain

sudo升级到安全版本1.8.27-1+deb10u3。


相关来源:奇安信CERT海青安全研究实验室